summary refs log tree commit diff stats
path: root/user/settings/fish.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/fish.nix')
-rw-r--r--user/settings/fish.nix18
1 files changed, 17 insertions, 1 deletions
diff --git a/user/settings/fish.nix b/user/settings/fish.nix
index a487418c..91d87505 100644
--- a/user/settings/fish.nix
+++ b/user/settings/fish.nix
@@ -9,10 +9,18 @@
         fromNixpkgs = pkg: { name = pkg.name; src = pkg.src; };
       in
       with pkgs.fishPlugins; [
-        (fromNixpkgs tide)
         (fromNixpkgs fzf-fish)
         (fromNixpkgs autopair)
         {
+          name = "fishplugin-hydro";
+          src = pkgs.fetchFromGitHub {
+            owner = "alanpearce";
+            repo = "hydro";
+            hash = "sha256-QYq4sU41/iKvDUczWLYRGqDQpVASF/+6brJJ8IxypjE=";
+            rev = "7a8c468ba0dc88a5f8a9c0b8635020bfc3619323";
+          };
+        }
+        {
           name = "ghq";
           src = pkgs.fetchFromGitHub {
             owner = "decors";
@@ -31,6 +39,14 @@
       set FZF_CTRL_T_COMMAND
       set --export FZF_DEFAULT_OPTS '--cycle --layout=reverse --border --height=90% --preview-window=wrap --marker="*"'
       fzf_configure_bindings --directory=\cx\cf
+
+      set --global hydro_multiline true
+      set --global hydro_color_pwd 00AFFF
+      set --global hydro_color_git 5FD700
+      set --global hydro_color_start FF00FF
+      set --global hydro_color_error D70000
+      set --global hydro_color_prompt 5FAF00
+      set --global hydro_color_duration 87875F
     '';
     shellAliases = {
       hist-freq-lines = lib.mkForce "history | sort | uniq -c | sort -gr | head -n100 | less";