summary refs log tree commit diff stats
path: root/user/settings/development/golang.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/development/golang.nix')
-rw-r--r--user/settings/development/golang.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/user/settings/development/golang.nix b/user/settings/development/golang.nix
index c0f92209..34a74896 100644
--- a/user/settings/development/golang.nix
+++ b/user/settings/development/golang.nix
@@ -15,6 +15,13 @@
   home.sessionPath = [
     "$HOME/go/bin"
   ];
+  home.shellAliases = {
+    gom = "go mod";
+    gomt = "go mod tidy";
+    gomd = "go mod download";
+    gog = "go get";
+    gogu = "go get -u";
+  };
   home.sessionVariables.GOTOOLCHAIN = "local"; # use installed go tools
   programs.emacs.extraPackages = epkgs: (with epkgs; [
     go-eldoc
@@ -24,8 +31,4 @@
   programs.neovim.plugins = with pkgs.vimPlugins; [
     coc-go
   ];
-  programs.fish.shellAbbrs = {
-    gmt = "go mod tidy";
-    gmd = "go mod download";
-  };
 }