summary refs log tree commit diff stats
path: root/system/settings/hardware/laptop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/hardware/laptop.nix')
-rw-r--r--system/settings/hardware/laptop.nix14
1 files changed, 4 insertions, 10 deletions
diff --git a/system/settings/hardware/laptop.nix b/system/settings/hardware/laptop.nix
index 17e27b63..bec1f7f6 100644
--- a/system/settings/hardware/laptop.nix
+++ b/system/settings/hardware/laptop.nix
@@ -17,17 +17,8 @@
       ];
     };
   };
-  systemd.services.bluetooth.wantedBy = lib.mkForce [];
-  systemd.timers.bluetooth = {
-    description = "Delayed startup of Bluetooth";
-    wantedBy = [ "timers.target" ];
-    timerConfig = {
-      OnActiveSec = "1 min";
-    };
-  };
 
   environment.systemPackages = with pkgs; [
-    blueman
     bluez-tools
 
     powerstat
@@ -65,6 +56,10 @@
     '';
   };
 
+  services.blueman = {
+    enable = true;
+  };
+
   services.xserver = {
     libinput = {
       enable = lib.mkDefault true;
@@ -73,7 +68,6 @@
     };
     displayManager.sessionCommands = ''
       ${pkgs.autorandr}/bin/autorandr --change --force
-      ${pkgs.blueman}/bin/blueman-applet &
     '';
   };