summary refs log tree commit diff stats
path: root/user/settings/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-08-25 05:55:57 +0200
committerAlan Pearce2023-08-25 05:55:57 +0200
commit13735084caa94892bba79bdb440556bbebfb4d53 (patch)
tree7c0fcfa173aaf2324d9e9c2237aa4c6c5ed3479e /user/settings/shell.nix
parentbd3083be8b43cb2e2e10a7456551cfc5fb0fde11 (diff)
downloadnixfiles-13735084caa94892bba79bdb440556bbebfb4d53.tar.lz
nixfiles-13735084caa94892bba79bdb440556bbebfb4d53.tar.zst
nixfiles-13735084caa94892bba79bdb440556bbebfb4d53.zip
fish: fix nix evaluation error
Diffstat (limited to 'user/settings/shell.nix')
-rw-r--r--user/settings/shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/user/settings/shell.nix b/user/settings/shell.nix
index cc827427..33332294 100644
--- a/user/settings/shell.nix
+++ b/user/settings/shell.nix
@@ -35,8 +35,8 @@ in
       https = "xh --default-scheme https";
       xhs = "xh --default-scheme https";
 
-      hist-freq-lines = "fc -l -10000 | cut -d' ' -f4- | sort | uniq -c | sort -gr | head -n100 | less";
-      hist-freq-commands = "fc -l -10000 | cut -d' ' -f4 | sort | uniq -c | sort -gr | head -n100 | less";
+      hist-freq-lines = lib.mkDefault "fc -l -10000 | cut -d' ' -f4- | sort | uniq -c | sort -gr | head -n100 | less";
+      hist-freq-commands = lib.mkDefault "fc -l -10000 | cut -d' ' -f4 | sort | uniq -c | sort -gr | head -n100 | less";
       wprop = "xprop | egrep '^WM_(CLASS|NAME|WINDOW_ROLE|TYPE)'";
 
       # Enable the following commands to support aliases.