{ ... }: {
  imports = [
    ./settings/darwin.nix
    ./settings/dev.nix
    ./settings/programs/shell.nix
  ];

  services.caddy = {
    user = "root";
    group = "wheel";
  };

  services.activate-system.enable = true;

  environment.variables.LANG = "en_GB.UTF-8";

  # Used for backwards compatibility, please read the changelog before changing.
  # $ darwin-rebuild changelog
  system.stateVersion = 4;

  # You should generally set this to the total number of logical cores in your system.
  # $ sysctl -n hw.ncpu
  nix.settings = {
    max-jobs = 8;
    cores = 4;
    auto-optimise-store = false; # https://github.com/NixOS/nix/issues/7273
  };

  nix.buildMachines = [
    {
      protocol = "ssh-ng";
      sshUser = "nixremote";
      hostName = "linde.alanpearce.eu";
      system = "aarch64-linux";
      maxJobs = 2;
      speedFactor = 1;
      supportedFeatures = [ ];
    }
  ];
}